Post Reply 
Author Message
MegaBoy Offline
I do things with squares
Banned

Posts: 15
Joined: Feb 2015

Post: #1
Glitches
Today I downloaded Quint's Revenge Everything was normal until I got to airman's stage... When I was on my last life I was teleported to the Boss room and won. Can any of you people tell me the cause of this glitch

MM - Happy
24-06-2015 02:19 PM
Find all posts by this user Quote this message in a reply
Rokim21 Offline
Obscure games deserve respect!
**
Registered

Posts: 12
Joined: Dec 2015
Reputation: 0

Post: #2
RE: Glitches
I have is bug: http://www.mediafire.com/view/yunxg2csys...ADtulo.png

P.S:All in my game is gray!!!
24-09-2016 01:21 AM
Find all posts by this user Quote this message in a reply
Azure-Mage Offline
Loves the smell of Starbucks in the morning
***
Registered

Posts: 58
Joined: Jan 2014
Reputation: 2

Post: #3
RE: Glitches
Hmm... Have you tried turning off the NES filter, Rokim21?
24-09-2016 02:18 AM
Find all posts by this user Quote this message in a reply
SUPAH METUL Offline
Megadrive-kun
**
Registered

Posts: 12
Joined: Sep 2016
Reputation: 0

Post: #4
RE: Glitches
1) Somehow I managed to damage Sniper Joe while he was in "shield" state(probably my netbook sucks, but maybe assynchronisation of states/sprites.
2) I got both Quint and robotmaster destroyed twice; in first case(that was Metal Man IIRC) I got weapon and proceeded to save screen, in second case(Wood Man) the game froze.
All those performed in current version downloaded from site.
24-09-2016 12:34 PM
Find all posts by this user Quote this message in a reply
Rokim21 Offline
Obscure games deserve respect!
**
Registered

Posts: 12
Joined: Dec 2015
Reputation: 0

Post: #5
RE: Glitches
(24-09-2016 02:18 AM)Azure-Mage Wrote:  Hmm... Have you tried turning off the NES filter, Rokim21?

NES filter?
24-09-2016 03:46 PM
Find all posts by this user Quote this message in a reply
Azure-Mage Offline
Loves the smell of Starbucks in the morning
***
Registered

Posts: 58
Joined: Jan 2014
Reputation: 2

Post: #6
RE: Glitches
Hang on a sec... I've checked the "Options" menu in Quint's Revenge and noticed there wasn't an NES filter option like in the sequel. My apologies about my guess being incorrect.
24-09-2016 09:34 PM
Find all posts by this user Quote this message in a reply
DarkSamus993 Offline
Keeper of the Archives
**
SIBRE Alpha Testers

Posts: 117
Joined: Jul 2012
Reputation: 11
Rhythm Co-Admin Award
Post: #7
RE: Glitches
(24-09-2016 01:21 AM)Rokim21 Wrote:  I have is bug: http://www.mediafire.com/view/yunxg2csys...ADtulo.png

P.S:All in my game is gray!!!

This issue has come up before. According to ACE it seems to be a problem with DirectX9.

The changelist for v30 (which hasn't been released yet it seems) lists a new shader option was added to fix the gray graphics issue.
25-09-2016 02:38 AM
Visit this user's website Find all posts by this user Quote this message in a reply
BBLIR Offline
Casual game developer
***
Registered

Posts: 65
Joined: Dec 2016
Reputation: 2

Post: #8
RE: Glitches
Something weird happened (version 1.0.36, might not be in 36a or b):
I the last Wily stage, I died ti Wily form one, game overed and continued. When I restarted, I heard the 'falling'(?) sound effect from the bossfight. But then it got weirder:
the screen transition worked like a boss door transition (with the sound but without the door), the boss theme started and I got stuck in this state:
Spoilers for Wily castle! (Click to View)
Also softlock.
17-04-2017 11:34 AM
Find all posts by this user Quote this message in a reply
Vucious Creed Offline
Newbie
*
Registered

Posts: 2
Joined: Apr 2017
Reputation: 0

Post: #9
RE: Glitches
Found a couple of bugs/glitches. Some that still remained from the older versions, and some probably new (whether any are intentional or not I won't know until stated otherwise). Note: these are taken from v1.0.36d (while being compared to v1.0.29 for some cases).

-In the Intro Stage, Wily 2 and Wily 3, you can still quick exit out of a level after hitting start (or any equivalently assigned button) after beating a boss during its explosions.
-In Metal Man's stage, if timed properly, one of the three mini-Changkeys before transitioning down to the next screen will fall along with you and be in the way. This issue still persisted since v1.0.29.
-Items can transfer from one Metal Catcher to another when fired again; specifically after the first Metal Catcher grabs an item. This causes the item grabbed by the first catcher to transfer to the second fired catcher and return virtually immediately.
-In Wily 3, the sheets of glass that protects you from the "mobile spike-ball rods of death" have an extended I-Frame hitbox. You can basically have about 90% of your body out of the glass and still not die from the spikes (as in completely wrapped around spikes and still not die as long as part of Quint's hitbox is in the glass). This has also been around since 1.0.29 and is present now (though I never realized this was a thing until recent).
-In Wily 6 (Wily Station), the second phase of the Wily Gauntlet, the tank form basically has no hitbox. You can clearly run in and out of the tank freely (though the glass is still a hurtbox).
-In the Wily Capsule/Time Skimmer fight, after dying, coming back to restart the fight causes Wily's AI becomes non-existant as it stays motionless until you defeat him. Safe to say you, as Quint, have full control as this occurs.

This is part more of a confirmation request rather than a bug/glitch report: Is the Kaminari Goro midboss in Air Man's stage supposed to have no hitbox to the main cardinal directions (up, down, left and right)? As I tend to skip this miniboss (for obvious reasons) before the current update I'm not completely aware of its mannerisms, so I just want to know if this is the case and it can be only hit at the corners of the screen. If he's supposed to be hit whenever he's on screen, then that's a problem. If not and that's how it was designed, then this can be ignored.

That should be it for possible bug and glitches that I've seen. Hopefully, these are of help. If not, well... at least it's good to re-confirm things, heh.
(This post was last modified: 19-04-2017 06:04 AM by Vucious Creed.)
19-04-2017 04:39 AM
Find all posts by this user Quote this message in a reply
ACESpark Offline
Stoke me a clipper, I'll be back for Christmas.
*******
Administrators

Posts: 933
Joined: May 2012
Reputation: 37
Tetris AwardSpike AwardRockman AwardRevo Remix ContributorSIBRE ContributorBooblight AwardRoll Caskett AwardSmash AwardAce Award
Post: #10
RE: Glitches
Thanks for the reports... looks like I am releasing another patch after all, although I am going to wait for Nico to finish his playthrough first.

19-04-2017 09:08 AM
Visit this user's website Find all posts by this user Quote this message in a reply
Flashman85 Offline
Minor Internet Celebrity
****
Registered

Posts: 239
Joined: Jan 2016
Reputation: 17
Beat AwardSpike Award
Post: #11
RE: Glitches
In the latest release, I died on the fight with Magnet Man at the same moment as I was pausing the game, and I got stuck on the inventory screen with no ability to close it out.

EDIT: This also happens at the start of a battle if you pause as a boss's energy just starts to fill.

No matter where you go, there you are.
(This post was last modified: 07-05-2017 05:40 PM by Flashman85.)
07-05-2017 05:04 PM
Visit this user's website Find all posts by this user Quote this message in a reply
Bored5555 Offline
Newbie
*
Registered

Posts: 3
Joined: Jun 2017
Reputation: 0

Post: #12
RE: Glitches
I have just recently downloaded and started playing the game. I haven't really done much, but I have decided to go after Magnet Man first, and noticed one interesting glitch in regards to pausing during his fight: if you time it correctly during the boss fight, before the moment where he reaches the top of his jump, the sprite for his weapon disappears right before he throws it out, he won't attack, and it forces him into a running position. In fact, pausing anytime while he is in midair, but not attacking, forces him into a running position.

Timing is required when it comes to pausing for preventing the attack from coming out, but it does seem to be quite precise, and I cannot determine a specific point as to when it will always stop the attack from coming out. If he were to attack twice, you'd need to be precise for timing the pause on both occasions (but since you can just spam the pause button, you'd just need to keep doing it until the sprite animations change from attacking to running in place).

Despite quite a bit of testing to see if the special attack would fall under the same category, I have not been able to cancel that attack in particular.

Edit: Forgot to mention that this is in the latest released build: v1.0.29. Being new here, I wasn't sure if this glitch I found was mentioned anywhere yet.
(This post was last modified: 04-06-2017 12:21 AM by Bored5555.)
03-06-2017 07:19 PM
Find all posts by this user Quote this message in a reply
Reflux Offline
Newbie
*
Registered

Posts: 3
Joined: May 2017
Reputation: 0

Post: #13
RE: Glitches
Apologies for the bump, but I also ran into something (playing 1.0.36). I got a game over against the boss in Wily 3, and coming back to fight him again his health didn't fill up properly; it only filled to where it had been when I died. And it wasn't just a graphical glitch, he died to 3 Leaf Shields after that.
(This post was last modified: 09-07-2017 07:14 PM by Reflux.)
09-07-2017 07:12 PM
Find all posts by this user Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread:
1 Guest(s)

Return to TopReturn to Content